Guadaliex 2013 en un portátil sin soporte PAE

En nuestro instituto, tenemos muchos ordenadores portátiles que tienen un procesador que no soporta PAE. No es un problema unicamente de Guadalinex, y se produce con todos los ubuntu, lubuntu, etc desde la versión 12.04, como podemos leer , o

Parece que esta característica esta disponible desde los microprocesadores Pentium Pro, por lo que no parece descabellado quitarle el soporte a procesadores de hace casi 20 años, pero hay un problema y es que algunos modelos de Pentium M con bus de 400 Mhz no tienen esta característica según leemos en y como ya habrán supuesto nuestros queridos portátiles tienen uno de esos procesadores, por lo que quedamos fuera de esta nueva versión de Guadalinex, que funciona realmente bien.

Así que busque como se podía solucionar este problema, haciendo pruebas con estos equipos y lubuntu pude conseguir una versión que esta especialmente diseñada para estos procesadores, pero en guadalinex esto no lo tenemos. Mirando con Google por internet vi esta solución es algo realmente simple, mirando el script, simplemente modifica la descripción de la cpu para indicar que si que soporte pae (aunque sea falso) y supuestamente el kernel funciona sin problemas.

Con todas esta información me dispuse a instalar Guadalinex 2013, como desde el portátil no podía porque me salta el problema del pae, saqué el disco duro (en realidad la que uso como disco duro) e instale en el Guadalinex desde otro ordenador que si soporte pae (ya sabéis, cualquiera desde Pentium pro, salvo los Pentium M con bus 400Mhz), simplemente desconectando su propio disco duro, y dejando solo el del portátil (recomiendo dejar el disco duro limpio sin particiones), y arrancamos la instalación por red de Guadalinex 2013.

Cuando termine tendremos en el disco duro Guadalinex 2013 instalado. Mi idea era conectar el disco duro a otro ordenador y añadirle el script que he enlazado antes, y que engaña al kernel, en la ruta /etc/rc pero antes de eso probé a arrancar el portátil con el disco, y la sorpresa es que arranco sin más problemas y funciona correctamente.

Ya he puesto un mensaje en Sigila para que añadan una opción en la instalación por red para los equipos que no tienen pae, ahora mismo la petición se encuentra en Evaluación(10%), esperemos que la admitan, porque supongo que habrá más institutos con estos equipos. Mientras tanto podéis hacer este apaño.

Anuncios